CtD on sleep

I experimented my first CtD clicking on the sleep button. Can I safely install the sleep fix available here? https://baldursextendedworld.com/My-Mods-2/


  • This is what it was made for.

    Just to check, you go to sleep and some party members are not fully healed? You then get a CtD.

    Note that with that fix you sometimes need to initiate the sleep a second time. In an inn this may require to buy the room again. An inconvenience but less inconvenient than CtD.
  • Thanks, will apply right now.
  • I tried running the setup. A cmd window opens, with the following:

    [C:\EET\00783\setup-RestFix.exe] WeiDU version 24400
    {Setup-A7#ImprovedArcher.exe} Queried (pid = 808) version = 24600

    That text stays there, nothing more happens..
  • Blash said:
    I tried running the setup. A cmd window opens, with the following:

    [C:\EET\00783\setup-RestFix.exe] WeiDU version 24400
    {Setup-A7#ImprovedArcher.exe} Queried (pid = 808) version = 24600

    That text stays there, nothing more happens..
    Ah, yes...that is weidu trying to update the version.
    Just close the window and try it again.

    If that does not help, do the following:
    - delete setup-Restfix.exe from your game directory
    - look for weidu.exe in the same directory
    - copy weidu.exe into the same location
    - change the name of the weidu-kopie.exe to setup-Restfix.exe
    - run the setup now
  • Wait, the fix makes so Greater Restoration is cast before sleep?  :o
    This way any level drain, ability drain etc. is cured. Is that right?
  • Blash said:
    Wait, the fix makes so Greater Restoration is cast before sleep?  :o
    This way any level drain, ability drain etc. is cured. Is that right?
    Look up the code, I do not remember. Luckily I never had to use it myself. I made it for someone who had the problem and then they asked me to share it.
  • The spell is CVRESTO.SPL. Do you know if it is the regulare Greater Restoration or a modified version that only heals damage? If it is really Greater Restoration, I have to uninstall the fix and just remember to quick save before resting.. 
    A tweak that quicksaves once you click on the rest button would be the best.
  • edited March 26
    This sounds like something I made myself. I cannot really remember the details. I looked at what caused the issue and then brewed a cure against it. It was just to help people who were desperate. Like I said, I could not do a real analysis of the underlying issue because I never had it. It cannot be the regular spell because that would be the one that is corrupted in the first place and causes the CtD.
    There should be no problem for you to just uninstall it again if you do not like it.
  • I forgot I could uninstall single WeiDU mods  :D
    Anyway, I found another solution. Since I use Logitech G13, I can use a macro.
    I can make so that when I press a single button, first the quicksave key is pressed, then the rest key. So, if there is a CtD, I can reopen the game and click on "Continue" to resume from right before the CtD.
  • Until the point where saving/loading the game take 10 minutes (which is mine situation) by ToB.
  • OMG  :o
  • 10 minutes is extreme.
    I have seen something like 15 seconds for a re-load when you are in ToB and have done nearly all big mods etc and your save is quite big.

    @LordSith however has constantly changed setup during the game and also tweaked saves with EEKeeper and NI a number of times, so there are side effects that are not normal.
  • edited March 27
    Oh I don't think those changes are responsible because it's not the game where I made the most change. Finally, here, I didn't change anything from EEKeeper since 3 weeks (that is 200 hours before now, on a total of 400 hours game at  the moment), using workarounds and the mod I constantly update only replaces items, a process I already did more than a 1000 times in my last game of 2017, where I did like a change for every mistake I found. this time, i just corrected what was bothering. But obviously, some mods are more responsible than others.
    (And with weidu, I haven't had much problems when my fixing mod is last in intall order ^^.)

    I think that's a byproduct of the number of variables the game has to check each time it saves (process which take 1 minute easily) [when it doesn't mess up and erase my autosave... it already ahppened 5 times, making me lose a ful 10 hours of game]. I tried to count them.

    That's why I already removed a lot of mods in my future installation which I will not need because they are not fun or not worth the (time)cost.

    Loading obviously is up to 10 minutes long.

    I tried putting the game on my SSD main drive,  because at the moment, it is running on my HDD, but well, at the opposite of my assumption, it changes nothing. I guess those old games are not reliant on the same things as modern games and a SSD doesn't help.

    All threads are pointing to too big saves, and comparing the size of my 2017 save (200ko at final TOB stage) and this one (20mo) I have to agree. (Obviously those numbers are only for the .sav and .gam files, not counting .bmp 's.)

    That's why i'm rushing towards the end, just wanting to see the end of the mods I chose first. There are a lot of mods which are empty under their cover and apparence of fun.

  • Your figures are unusual.
    The final save from my last year's campaign with a full set of mod and the addition of the Sandrah extensions beyond ToB resulted in a save file of 6,5 MB which takes about 10 seconds to load on my PC. (This is the save from the Eroan's Journey Adventure Log that I published here on the forum, so you see it is from an "all-you-can-eat" game.
  • edited March 27
    Ah I am sure that is not usual. The fact is my first "something is wrong" clue came from the dock map. You may remember that issue.

    I don't know if the "trouble" comes from there, I don't know which mod caused it, but now I can't do anything about it.

    In full, this run was not the most fun for some reasons. First are mods who brings only fight fight fight at the cost of rythme and pace in the game. Second is... well you already know it, I discussed it plenty on these forums, Sandrah mod. Third is now this "slow loading".

    So that's why I'm in hack&slash mode. (Besides the fact that with XP I have, it really is hack&slash for most encounters; last one who provided some challenge was Demongorgon, but only because I messed up 2 times*, forcing 2 reload, so a full 20 minutes lost... At that point I decided my time more valuable, and started resorting to ctrl+R instead of having to reload.)

    * Well once on me.
    The second is on that f****g "I stay on my mistress and prevent her to move" creature which caused charname to die due to the sheer brutality of Demongorgon attacks. If I could have moved, turn to Ravager, and its 350HP and immunities, it would have been different.

    For example, I'm now supposed to go to waterdeep.

    Did that yesterday.
    First try? I didn't swear the oath, lost Sandrah. First reflex was "good riddance, let's kill the family" then irl the player was like "pff all this for that? One sentence not implying i will betray her, and she goes off? what a fucking moron"
    Then "... let's reload, I will never do Sandrah again but if i stop this, all the run is completely useless".

    Reload [10 minutes]

    Back to waterdeep. Good forced choice mandatory...
    move to another spot...

    Crash on auto save.

    => taken back to my quicksave after Yagashura death. Yeaaaah I have to go to Waterdeep again, talk to elminster, again, talk to Sandrah again, and hoping none of those auto-save erases the autosave. And remmeber to quick save often.

    Conclusion? i'm now in Amkethran and not really feeling like going to waterdeep. :/
  • edited March 27
    Update: the game crashes even at full health. Will try resting in another area to see if there is any connection. I'm lost at the moment.

    Update: I changed area, didn't crash. How can I display the area code I'm currently in? Otherwise I'll try explaining with my own words.
  • Area code appears when you type "x" while your mouse is in the area (also gives you the x/y position).

    If it is not the corrupted restoration spell that causes the CtD it may be some dream that triggers. Maybe one of your companions triggers one. Who is in your party? "changed areas" does that mean inn vs outdoors?

    You can also post the file Player1d.bcs here and I can take a look if something is wrong there.
  • Crash on rest happens *only* in DSC023. It doesn't matter if I'm at full health or not, it crashes only there. 

    Curious detail: with your tweak it didn't crash in DSC023.
    Without your tweak (uninstalled) both with full health and while injured the game crashes.

    No crash outside DSC023.

    That's really weird.

  • DSC023 is a mod added area.
    One possibility therefore may be a wrong file in the "Rest interrupt" definition of that area. This happens if your sleep is interrupted by monsters but the one expected to appear either does not exist or is corrupted. It also would explain why it is random.

    Check this
  • Creature correctly created. And killed. And dropped nice scroll. Thanks  :p
  • Blash said:
    Creature correctly created. And killed. And dropped nice scroll. Thanks  :p
    Well, that was not the solution then. "Creature not found" would have explained the CtDs...
    So, we still do not know.

    Do you play some non-English language?
  • No, 100% English. If the problem is limited to that area, I suppose it's not a big deal if we don't find out.. maybe you could add a warning in the fixpack, a sign that says "resting in this area is forbidden"  :#
  • I just tested it on my own EET installation. It is indeed weird.
    I had a CtD upon resting if some party member was injured. Only in this particular area.

    I think I found the issue.
    It is the Rest Interupt - a mismatch between the number of creatures to be spawned and the actual creatures defined to spawn. After correcting it, there are no further CtDs and the creature to disturb spawns correctly.
  • Maybe it is the cause for the CtDs reported by others? 
  • Blash said:
    Maybe it is the cause for the CtDs reported by others? 
    I doubt it. This is a very local problem. It happens in some areas for similar reasons, i.e. the rest encounters are erroneous. It is not the explanation for the healing procedure during rest to cause CtDs, that is a mod that changes a spell.
    There are also some other bugs that may cause CtDs on resting.
    One symptom can have different reasons.
Sign In or Register to comment.