Can't download few mods

edited November 2019 in Install Tool Help
I can't seem to download MadeInheavenItemPack  https://github.com/AngelGryph/MadeInHeaven_ItemPack and FisihingForTrouble from lynxlynx https://github.com/InfinityMods/FishingForTrouble

Any reason they are not pulled from github?

Comments

  • edited November 2019
    Try these links
    and

    After you downloaded the mods however, you need to extract them manually to your BG2EE. Just open the zip files and extract just the mod folders, i,e. FishingForTrouble and mih_ip respectively from the archive - note that they are inside the main folder of the archive, so you have to go down one level.

    PS - I have updated the links and extraction logic based on your finding. It has happened in the past on occasions that those lynxlynx links failed sometimes.

    Thank you.
  • Hey Roxanne, I've also noticed a weid issue. I'm trying out different combinantions of mods and when you stop installation after downloads were no found and relaunch the app or after installation has completed and you also relaunchit, I get error dialog that BG2EE/Mod.ini has invalid Name.



    on line 575. Clearly because of the duplicated BoM entry. I've checked the master branch and it looks good so the only conclusion I can come up with is that there is some logic error inside the app that inserts this after said occassions.

    No clue why that happens, just curious if you also encountered it :)

  • I have never seen this but maybe the reason is that I always use a fresh download when I do a new installation. I take the "downloaded mods" to a save place, delete old tool, download new version, put pack the mods folder and start clean. If I want to use a previous selection I export the file under a dedicated name (as described in the pdf-file for "compilations"-handling.
  • edited November 2019
    Found the topic that mentions that error
    http://baldursextendedworld.com/Vanilla_Forums/discussion/411/improperly-formatted-mod-ini-file-at-line-575-help#latest.

    Just to be clear: After those two situations happend described in my prevoius post and you exit and try to launch the app it will show the error preventing it to even start. There is no option to i.e continue previous installation in case stopping it after failed download. The error shows during bulding the GUI.

    The only thing which helps is to launch "Update EE Mod Setup" which will pull the fixed file from repo.

    Since you delete the tool when making new install and download it anew, it might be why you were unware of the issue :) 
  • Hm, maybe this is a general misunderstanding here. I never considered the install tool as a program that you keep and re-use. For me it is a helper I use to make an installation and afterwards throw away. Next time I do an installation I take the latest version and use that etc... Same for mods, I do not store them because many will be revised already the next time I use them.

    Maybe it just helps to delete that ini-file for the cases you describe? I see no point why you would want to load it a second time.
  • All is selected and conflicts accounted for, checking downloads im getting this:

    -Summary-
    These selected downloads are defect:

    Tales of the Deep Gardens
    Auren Aseph NPC
    Chatty Imoen


    how can i solve it ?
  • I manually downloaded chatty imoen and auren aseph and put them in the mods download for EET, they are found as having the expected size, however tales of the deep gardens says the file does not have the expected size.
  • kaldgord said:
    I manually downloaded chatty imoen and auren aseph and put them in the mods download for EET, they are found as having the expected size, however tales of the deep gardens says the file does not have the expected size.
    You can just say (f)orce if the size does not fit.
    Note - sometimes it helps to enlarge the window of the Install Tool to see all text.

  • Ok that has worked. Now moving on with the new installation, some more errors popping up, like this one:

    The extraction of the following mod(s) failed:
    Item Upgrade: The Mod itself (master.zip)

    Some files were not extracted. Do you want the tool to run an integrity test on those files first, provide the files yourself (see remarks) or just continue?
    Enter [t]est, [p]rovide or [c]ontinue.
  • There was a download error from github, this may happen randomly with that host if overloaded. Item upgrade was downloaded without the mod name attached to the archive, i.e. just named master.zip.
    Download again from here https://github.com/Gibberlings3/Item_Upgrade/archive/master.zip, then put it into the download folder and use (p)rovide to point it to the tool.
  • Ok, that seem to have worked, installation moved on after I provided it although there was a message that made it look like the mod was skipped, but so far its working. 
    Ive also installed everything out of C: in my secondary D: disk which i keep for games but out of the protected drives

  • ##### Item Upgrade #####
    The mod was not found.
    After the mod is present, the install may be started another time.
    Enter [r]etry, [c]ontinue or [e]xit.


    Seems im not out of the woods yet, the installation isnt moving forward, now showing this error, although the mod is indeed in the proper download folder.
  • Maybe it was not unpacked?
    Extract it to the BG2EE directory you use. Make sure that you extract the folder "itemupdrade" out of the wrapper "item_upgrade-master" folder. You only need that inner folder in the BG2EE directory.
    Now (because that would have been done earlier) you need to make a copy of weidu.exe from the game directory and re-name that copy to setup-itemupgrade.exe. Then (r)etry.

    If the last step does not work, just start the setup-itemupgrade.exe manually, install the mod and then select [c]ontinue
  • ok, thanks. 
    But what could be the cause for the tool to having this error ? can it be patched ?
  • kaldgord said:
    ok, thanks. 
    But what could be the cause for the tool to having this error ? can it be patched ?
    The issue is with github hoster under some load conditions, it is not on the receiving end. It is known but random. Even with this, github is still the most reliable source for mod downloads.
    More information can be found here http://baldursextendedworld.com/Vanilla_Forums/discussion/comment/7505/#Comment_7505 and in the subsequent posts.
  • It seems that some mods have their zip file named as "master.zip"

    Hidden Adventures: The Mod itself (master.zip)
    Check the Bodies Candlekeep Memories: The Mod itself (master.zip)
    Check the Bodies Of Elves and Artefacts: The Mod itself (master.zip)

    I was not able to install them altogether in a single installation. If I were to provide the file manually, it would just overwrite the previous "master.zip" of other mods. 
  • I would like to report some failed downloads links : 

       Wilson Chronicles: The Mod itself (Wilson Chronicles v1.5.zip)
       Ulrien Of Cormyr, Saga Master (new): The Mod itself (Ulrien-SagaMaster.zip)

       Tales of the Deep Gardens: The Mod itself (Tales of the Deep Gardens v12.4.zip)
       Mage Stronghold: The Mod itself (V0.4.zip)
              https://github.com/RoxanneSHS/Magestronghold/archive/V0.4.zip

    Wilson Chronicle mod has an updated version (1.7) on author's website, blackwyrmlair site  (for Ulrien of Cormyr mod) looked unreachable, the github link to mage stronghold mod isn't working, and same thing for the dropx box link to Tales of the Deep Gardens mod.
  • edited May 10

    Deep Gardens has not changed and it works fine for me. Depending on your provider, you may need to use manual download to overrule some flood or spam control - this happens occasionally with that hoster.
  • I've checked magestronghold is working fine now, thank you. Other links seems functional either, dunno why it was not working this morning, but it's ok now. Thank you Roxanne
Sign In or Register to comment.