FFT Ring Quest

Hello!
i just realized a bug with the Ring Quest from FFT (given by lady in in Goverment 2)
If I talk to Lug_whatsoever (Thieves Guild)  the screen freezes ("You can have it...") instead of giving the ring!

Nothing helps except restart the game and avoid the dialogue
Anyone else with this issue ?

Comments

  • edited July 2018
    The dialogue has bugs for all of the existing responses as they all lead to non-existing lines due to wrong coding:

    IF ~Global("ys_TalkedToLugh","GLOBAL",0)~ THEN BEGIN 5
        SAY @2559
        IF~~ THEN REPLY ~~
        THEN DO~GiveItemCreate("ysepring",Player1,0,0,0)
            AddexperienceParty(1000)
            EraseJournalEntry(@152)
            SetGlobal("ys_TalkedToLugh","GLOBAL",1)
            SetGlobal("ys_LughOkay","GLOBAL",1)~
        EXIT
    END

    IF ~Global("ys_TalkedToLugh","GLOBAL",0)~ THEN BEGIN 6
        SAY @2561
        IF~~THEN REPLY @2562 GOTO 7
    END

    IF ~Global("ys_TalkedToLugh","GLOBAL",0)~ THEN BEGIN 7
        SAY @2563
        IF~~THEN REPLY ~~
        DO~SetGlobal("ysLughFight","GLOBAL",1)
              EraseJournalEntry(@152)~
        EXIT
    END


  • I suggest to skip the dialogue and just give yourself the item with console
    C:CreateItem("ysepring")
  • Further information:

    The mod is hosted on github, so I made the necessary corrections there and just tested the modification successfully. The issue should be solved with this.
  • Hello roxanne,
    thnx a lot!

    rather strange that this bug "survived" all the years as long as FFT existed
    its not an EET bug then....
    even stranger, that no one else encountered this bug....
    not even the key "0" or "1" were working....

    but I will use your tip with the console for now.....

    Thnx again
  • Just out of curiosity I checked the dialogue in an old BGT installation I still have on an external drive. The bug is already there in the original version before it ever was converted to EE.
    Difference is that in the old game you could overcome the *freezing* by typing in *1* for the not existing answer and you received the ring. That is no longer possible in EE.

    Interesting finding, but it may explain how the few players that do the FFT side-quests worked around it in the past?
Sign In or Register to comment.