EET and Patch 2.5

edited July 21 in EET Help
Topic
This topic is intended to summarize the impact of the vanilla game(s) update to version 2.5 and possible resulting issues for EET (or single games) and other mods. Some problems have been identified and were discussed/resolved under different headlines. I think it makes sense to summarize them in a single topic.

Status
The update for BG2EE has started and users are migrating to the new version. The update for BGEE/SoD has been announced and some limited beta testing is ongoing.
The current situation for most users of EET would be that BG2EE is now at v2.5 while other parts are still 2.3.67.
The following topics are based on this constellation.

Issue1 - Spells changed
A number of spells have been modified in a way that causes the failure of components in the SCS, EET-Tweaks and Spell Revision mods. (Those mods were reported already, others may be affected but not yet known.)

Solutions
1. The EE/EET Mod Install Tool https://baldursextendedworld.com/Install-Tool/ has an  automatic workaround implemented. If you use the tool you do not need to worry.
2. A manual workaround is described in the same link mentioned above for the spell list.

Issue2 - GUI change
The log message window keeps jumping to the top (oldest information) whenever opening the inventory or going through a dialogue. The quick save button is disabled although "Q" hotkey works.

Solution

Solved with EET RC 10 (but do not use the EET_GUI (SoD) because SoD is still on version 3.2 - use standard GUI or one of Lefreuts UI mods

Issue3 - EET Core Installs with warnings
You get these warnings during EET Core installation
WARNING: Could not find block matching .../oBALDUR.baf in BALDUR.BCS
WARNING: Could not find block matching .../oBALDUR.baf in BALDUR25.BCS
WARNING: could not find See(NearestEnemyOf(Myself))[
WARNING: could not find "IMOEN" in BIMOEN25.DLG
Enhanced Edition Trilogy (Enhanced Edition Trilogy) was installed with warnings.
EET tries to patch errors that still existed in v2.4.67 but are now fixed in v 2.5. EET serves both game versions at the moment. The erroneous code no longer exists so EET does not find it.
Note - Some spell and kit mods show similar warnings when they try to apply corrections that are now already included in the updated vanilla game.

Solution
These warnings can be ignored.


Solved with EET RC 10

Issue4 - Some creature files embedded in areas
This was reported by users of the BGEE beta. It may or may not be solved when the official release for BGEE/SoD will be shipped out.

Solution
The EE/EET Mod Install Tool https://baldursextendedworld.com/Install-Tool/ has an  automatic workaround implemented. If you use the tool you do not need to worry.
«134

Comments

  • Hi Roxanne! First off, I just want to say thank you so much for keeping this tool alive and growing! I would no be trying to do my first trilogy run in like 10 years if it weren't for you keeping this beast of a mod tool alive!

    I'm having a problem with EET following the BG2 2.5 update. For whatever reason it's now throwing me errors where my previous install before the update went fine. I am using your exploring the EET world compilation to do a run with Sandrah and through the Big Mods for the first time with minor alterations such as a few Tweaks Anthology Tweaks, Jim's Tweaks, and more of the SCS AI components like Smarter Priests and Improved Vampires.

    I'll post a few of the warnings, wait or SCS to finish running (my last install attempt SCS failed and rolled itself back but I'm unsure if it was before or after you updated it), and post the debug file later if needed. I'm noobish to BG modding so I apologize if this is nonsense!

    INSTALLED WITH WARNINGS     EET core - resource importation

    C:\Users\Doombox\Desktop\Baldur's Gate Trilogy\Baldur's Gate II Enhanced Edition>
    WARNING: Could not find block matching .../oBALDUR.baf in BALDUR.BCS
    WARNING: Could not find block matching .../oBALDUR.baf in BALDUR25.BCS
    WARNING: could not find See(NearestEnemyOf(Myself))[
    WARNING: could not find "IMOEN" in BIMOEN25.DLG
    Enhanced Edition Trilogy (Enhanced Edition Trilogy) was installed with warnings.

    INSTALLED WITH WARNINGS     Add Acolyte of Moander
    INSTALLED WITH WARNINGS     install Sphere System
    WARNING: no effects altered on SPPR331.spl
    WARNING: no effects altered on sppr420b.spl
    ((These from Faiths and Powers, which threw a few more warnings I believe))


    Any help figuring this out would be super appreciated! Again, thanks for keeping this tool up-to-date and contributing so much rad content to this community! 

    Oh! One last question! Is the Exploring the EET World compilation the one you'd use on a new playthrough to do Sandrah + Big Mods + SCS? I'm curious what you'd use/suggest for a big world run!
  • edited July 4
    My first test installation with patch 2.5 is still running (thanks to SCS going into its the 12th hour now).

    But I had already time to analyze the EET warnings you quoted. I have exactly the same ones. Ignore them. EET tries to patch what is already corrected and it cannot find the incorrect code it it looking for. These checks can be removed in the next EET update.

    With respect to spells, a number of them are altered in the 2.5 patch. I would expect that F+P - which is a very dynamic mod - will soon be updated for the new version. I cannot anticipate any problems from those warnings. The modded version is equal to the vanilla version of the spell, so there should be no bug.
    The only real issues found so far with spells are the ones discussed here https://forums.beamdog.com/discussion/comment/990451/#Comment_990451 and which hopefully are solved by the Install Tool.

    The EET compilation I provided is more of an example that tries to grab some mods of every colour to try out EET. It contains mods that I have played and tested myself so I know they all work consistently together. For myself, I usually use larger and more experimental collections which I decided not to share - the idea behind compilations is that other who use them can rely on the experience made before by the one who submits them. This is not the case for my own game where I take any risk to try out new things or find/remove bugs etc.

    PS I made a couple of notes concerning my 2.5 EET experiment which I planned to post as soon as the installation has finished. Anyway, my first impression of the new build in combination with EET is that there are no big issues except the one with the few spells and the GUI and both can be worked around.
  • Thanks so much for the super quick response! Ok good to know! I'll ignore the warnings and keep my eye out for any trouble with SCS (mine will likely be going for the next 12+ hours as well). I'll let you know if I stumble in to anything. I'll keep my eye out for the experiment, I'm actually very interested to see what load order you're playing around with.

    Just gotta say thank you again for helping me!
  • edited July 11
    Findings from my EET installation with BG2EE v2.5.16:and BGEE/SoD v2.3.67

    I made a quite large EET selection with mods of all types.
    I used the EE/EET Mod Install Tool.
    The complete installation took 2 hours including mod downloads plus another 14h for SCS.
    There were no incidents during the whole process
    I attach the logs for reference which mods were included in my test.

    Detailed issues

    1) INSTALLED WITH WARNINGS     EET core - resource importation

    WARNING: Could not find block matching .../oBALDUR.baf in BALDUR.BCS
    WARNING: Could not find block matching .../oBALDUR.baf in BALDUR25.BCS
    WARNING: could not find See(NearestEnemyOf(Myself))[
    WARNING: could not find "IMOEN" in BIMOEN25.DLG
    Enhanced Edition Trilogy (Enhanced Edition Trilogy) was installed with warnings.

    Analysis: These warnings can be ignored. EET tries to correct issues that are now fixed in the game. Thus the *could not find*. It means it could not find the erroneous code.
    (Reference - EET bg2_BCS.tph = file containing BG2 script corrections)

    2) Adrian v4.2 failed automated extraction.

    Analysis: Solved in the install tool. If you do manual install you may need to use the 7z program to unpack the rar file.

    3) EET_Tweaks NOT INSTALLED DUE TO ERRORS XP for quests -> Decrease to 50%

    Analysis: The reason for failure is again one of the changed spells already identified for SCS and SR issues. Solution will be the same as in the other cases. Automated workaround will be added to the Install Tool right away.

    4) lefreut GUI was installed manually after the tool finished

    Analysis: I included the mod in the selection but noticed that the configuration was not yet updated to the latest version. This is corrected meanwhile.
    The GUI mod is currently the only one usable for EET that is already adapted to changes made by patch 2.5 to the GUI.

    ___________________________________________________________________________
    (Personal subjective) Summary
    Apart from the known issues listed in the first post of this topic, no real problems were found - the minor issues listed above are of a nature that I consider normal for such a large modded game and nothing to worry about.
    There is no evidence that the new update has a catastrophic impact on the modding scene or whatever else some people may be afraid of. Given this, I am confident that the patches for the other game parts will be equally compatible with the majority of mods.
  • Thanks so much for the super quick response! Ok good to know! I'll ignore the warnings and keep my eye out for any trouble with SCS (mine will likely be going for the next 12+ hours as well). I'll let you know if I stumble in to anything. I'll keep my eye out for the experiment, I'm actually very interested to see what load order you're playing around with.

    Just gotta say thank you again for helping me!
    The main finding in my test install was another case of updated spells causing a problem - this was in EET_Tweaks experience reduction.
    The already tested function for SCS and SR will be used in the install tool for this case as well.
  • I'll keep my eye out for the experiment, I'm actually very interested to see what load order you're playing around with.

    Just for information, I just do a little test playing with that new installation and check out a few crucial points to see if there are any problems. I will not use this version at all to play it. This was just technical research. So the selection is rather random and focuses on critical mods rather than to take playing it into account.

    For playing I still continue to use my large 2.3.67 version that I will finish before I actually use the updated version myself. There is nothing in patch 2.5 that I personally find important enough to trash my current adventure for it.
  • edited July 5

    I'm having a problem with EET following the BG2 2.5 update.

    INSTALLED WITH WARNINGS     Add Acolyte of Moander
    INSTALLED WITH WARNINGS     install Sphere System
    WARNING: no effects altered on SPPR331.spl
    WARNING: no effects altered on sppr420b.spl
    ((These from Faiths and Powers, which threw a few more warnings I believe))
    Info - F+P mod has been updated, the link in install tool has been updated as well. I have not tested the new version but anyway, if there are issues they will be corrected by the active mod maintenance for F+P.

    As a general rule, workarounds like the ones for SR, SCS and EET_Tweaks will only be added to the install tool if the implementation would otherwise fail and it is foreseeable that a solution within the mod itself may take significant time (if it is updated at all). The F+P is an example where active modders take care and it makes no sense to interfere with their solution finding.
  • Looks like I got all the same errors as you and that you fixed them all already! Super impressive!

    Since I won't be able to play for 48 hours anyway I'm doing another install right now with a few more mods (IR + SR + your updated compilation) and will report back if I have any issues during the install!
  • Twice now I have gotten this error from Spell Revisions.

    Installing [Dispel Magic Fix] [v4 Beta 14 EE Fix]
    Copying and patching 2616 files ...
    ERROR: illegal 2-byte read from offset 3145914 of 8394-byte file SPWI618.SPL
    ERROR: [SPWI618.SPL] -> [override/SPWI618.SPL] Patching Failed (COPY) (Failure("SPWI618.SPL: read out of bounds"))
    Stopping installation because of error.
    Stopping installation because of error.

    ERROR Installing [Dispel Magic Fix], rolling back to previous state
    Will uninstall  10 files for [SPELL_REV/SETUP-SPELL_REV.TP2] component 30.
    Uninstalled     10 files for [SPELL_REV/SETUP-SPELL_REV.TP2] component 30.
    ERROR: Failure("SPWI618.SPL: read out of bounds")
    Please make a backup of the file: SETUP-SPELL_REV.DEBUG and look for support at: marco.montagnoli83@hotmail.it
    Automatically Skipping [Dispel Magic Fix] because of error.

    Not sure what's going wrong.

  • Twice now I have gotten this error from Spell Revisions.

    Installing [Dispel Magic Fix] [v4 Beta 14 EE Fix]
    Copying and patching 2616 files ...
    ERROR: illegal 2-byte read from offset 3145914 of 8394-byte file SPWI618.SPL
    ERROR: [SPWI618.SPL] -> [override/SPWI618.SPL] Patching Failed (COPY) (Failure("SPWI618.SPL: read out of bounds"))
    Stopping installation because of error.
    Stopping installation because of error.

    ERROR Installing [Dispel Magic Fix], rolling back to previous state
    Will uninstall  10 files for [SPELL_REV/SETUP-SPELL_REV.TP2] component 30.
    Uninstalled     10 files for [SPELL_REV/SETUP-SPELL_REV.TP2] component 30.
    ERROR: Failure("SPWI618.SPL: read out of bounds")
    Please make a backup of the file: SETUP-SPELL_REV.DEBUG and look for support at: marco.montagnoli83@hotmail.it
    Automatically Skipping [Dispel Magic Fix] because of error.

    Not sure what's going wrong.

    Put the attached file into bg2ee/spell_rev and try again. It is yet another case of the revised spells.
  • You rock! Doing another install now!
  • Got this error again.

    ERROR: illegal 2-byte read from offset 3145914 of 8394-byte file SPWI618.SPL
    ERROR: [SPWI618.SPL] -> [override/SPWI618.SPL] Patching Failed (COPY) (Failure("SPWI618.SPL: read out of bounds"))
    ERROR: Failure("SPWI618.SPL: read out of bounds")
    Dispel Magic Fix (Spell Revisions v4 (pre-release)) was not install

  • Got this error again.

    ERROR: illegal 2-byte read from offset 3145914 of 8394-byte file SPWI618.SPL
    ERROR: [SPWI618.SPL] -> [override/SPWI618.SPL] Patching Failed (COPY) (Failure("SPWI618.SPL: read out of bounds"))
    ERROR: Failure("SPWI618.SPL: read out of bounds")
    Dispel Magic Fix (Spell Revisions v4 (pre-release)) was not install

    This is weird. I just tested the revised tp2 file with all SR components and they install without any error.
    ~SPELL_REV/SETUP-SPELL_REV.TP2~ #0 #0 // Spell Revisions: v4 Beta 14 EE Fix
    ~SPELL_REV/SETUP-SPELL_REV.TP2~ #0 #10 // Deva and Planetar Animations: v4 Beta 14 EE Fix
    ~SPELL_REV/SETUP-SPELL_REV.TP2~ #0 #20 // Mirror Image Fix: v4 Beta 14 EE Fix
    ~SPELL_REV/SETUP-SPELL_REV.TP2~ #0 #30 // Dispel Magic Fix: v4 Beta 14 EE Fix
    ~SPELL_REV/SETUP-SPELL_REV.TP2~ #0 #50 // Remove Disabled Spells from Spell Selection Screens: v4 Beta 14 EE Fix
    ~SPELL_REV/SETUP-SPELL_REV.TP2~ #0 #55 // Spell Deflection blocks AoE spells: v4 Beta 14 EE Fix
    ~SPELL_REV/SETUP-SPELL_REV.TP2~ #0 #60 // Update Spellbooks of Joinable NPCs: v4 Beta 14 EE Fix
  • edited July 6
    I just tried a second time and got it again strangely. I'm not sure why. Could there be a mod in my order tripping it up?

    Edit - attached my compilation. Iduno if that helps, maybe I'm doing something way dumb?

  • I just tried a second time and got it again strangely. I'm not sure why. Could there be a mod in my order tripping it up?
    Try this alternative:
    Extract the attached files into bg2ee/override before running SR-setup. It is possible that some previous operation has messed up something but there is no way to find that.
  • edited July 6
    Giving it a go now. Edit - you are awesome for helping me!

    Edit 2.0 - That worked!!!! THANK YOU!!!

    Edit 3.0 Now Faith and Powers is putting out warnings.

    WARNING: no effects altered on SPPR333.spl
    WARNING: no effects altered on sppr420b.spl
    WARNING: no effects altered on SPPR605.spl
    WARNING: no effects altered on SPPR605.spl
    WARNING: no effects altered on SPPR605.spl
    WARNING: no effects added to spwi312.spl
    WARNING: no effects added to spwi312.spl
    WARNING: no effects added to spwish25.spl
    WARNING: no effects added to spwish25.spl
    WARNING: no effects added to spin977.spl
    WARNING: no effects added to spin977.spl

    Are these serious? They seem serious lol.
  • edited July 6

    Giving it a go now. Edit - you are awesome for helping me!

    Edit 2.0 - That worked!!!! THANK YOU!!!

    Edit 3.0 Now Faith and Powers is putting out warnings.

    WARNING: no effects altered on SPPR333.spl
    WARNING: no effects altered on sppr420b.spl
    WARNING: no effects altered on SPPR605.spl
    WARNING: no effects altered on SPPR605.spl
    WARNING: no effects altered on SPPR605.spl
    WARNING: no effects added to spwi312.spl
    WARNING: no effects added to spwi312.spl
    WARNING: no effects added to spwish25.spl
    WARNING: no effects added to spwish25.spl
    WARNING: no effects added to spin977.spl
    WARNING: no effects added to spin977.spl

    Are these serious? They seem serious lol.
    I have done another big EET install, including SR (I left out SCS this time to save time).
    _ SR installs without errors
    - EET_Tweaks installs without errors

    Faith and Powers gives me similar warnings. I looked at the debug.log details and I do not think those warnings are serious for patch 2.5. Just remember that F+P is a mod that can be installed on ALL EE games. For some, it is required to add or remove usability flags in order to assign the spells to new priest kits. This seems to be not the case anymore for some spells now in patch 2.5. According to the logs, these spells with *no added effects* are afterwards successfully associated with the F+P kits. Those warnings are similar to the EET ones earlier, where the mods try to patch something that is no longer required in 2.5.

    (Note that this is analysis from *paper*, i.e.from logs and code inspection, I have not evaluated this in game.)
  • edited July 6
    Can't thank you enough for helping me with this!


    SCS is throwing out a ton of warnings like this now. Can't tell if I should ignore these or not? There are a bunch of warnings like this in my debug log now. Edit - had to cut chunks of the warning out to fit it in the post. Should I up my debug log?
    Edit 2.0 - added debug log so errors can be viewed.
    Edit 3.0 - SR and EET Tweaks both installed issue free for me this time.

    Warning: it looks as if some entry that should be a key=>value list, isn't (~list~ is currently =>                                                    ~opcode=171 and parameter2=0 and resource=SPPR213~ delete_effect                                                    =>                                                    ~opcode=171 and parameter2=0 and resource=SPPR312~ delete_effect                                                    =>                                                    ~opcode=171 and parameter2=0 and resource=d5pp412~ delete_effect                                                    =>                                                    ~opcode=171 and parameter2=0 and resource=SPPR406~ delete_effect                                                    =>                                                    ~opcode=171 and parameter2=0 and resource=SPPR507~ delete_effect                                                    =>                                                    ~opcode=171 and parameter2=0 and resource=SPPR513~ delete_effect                                                    =>                                                    ~opcode=171 and parameter2=0 and resource=SPPR603~ delete_effect                                                    =>                                                    ~opcode=171 and parameter2=0 and resource=SPPR612~ delete_effect                                                    =>                                                    ~opcode=171 and parameter2=0 and resource=SPPR706~  delete_effect                                                    =>                                                    ~opcode=171 and parameter2=0 and =>                                                    ~opcode=171 and parameter2=0 and resource=SPPR707~, key=opcode=171 and parameter2=0 and resource=SPPR108)
    Appending to files ...
  • This is an explanation from Might and Guile but it may be applicable for other kit + spell mods (Faith and Powers, Tome and Blood) in a similar way.
    I think it is a change that was implemented after some modders found the previous vanilla behaviour to be erroneous. So again, not  a problem. Anyway, I suggest to ask the modder directly if you want a more expert confirmation.
  • edited July 6
    You are just a wealth of information on this! That thread was exactly what I was looking for! Thanks so so so so much for all your help!

    Edit - I gotta say this process would have been impossible without you! I simply would have been unable to track down this information alone. The BG community is so wide-spread, and sources of info so inconsistent across the various forums (G3, Beamdog, ect) that it's neigh impossible for a newb to sort through it all without knowing exactly where to look. Googling SR issues and pulling up up forum posts from 2015 was getting unbelievably frustrating.

    Also, gotta say, thanks for the modern layout of this forum! Way easier to find info in here than on any of the other forums I've been looking.
  • Just for information, I just do a little test playing with that new installation and check out a few crucial points to see if there are any problems. I will not use this version at all to play it. This was just technical research. So the selection is rather random and focuses on critical mods rather than to take playing it into account.

    For playing I still continue to use my large 2.3.67 version that I will finish before I actually use the updated version myself. There is nothing in patch 2.5 that I personally find important enough to trash my current adventure for it.

    Thanks for pulling this right out of my mind!  I have two adventures running currently on a 2.3.67 install for Shandrah and another Mega Mod (Drizzt) I'm in the middle of, so I should just finish those up before I try to do anything with a 2.5 patch right?

    That is pretty much what I had intended, because I figured EET wouldn't play drastically different with 2.5 and since I'm running them on Beamdog Versions I don't have to worry about them trying to update automatically.  I also dedicated a separate drive to run BG and IWD games and to have a wide open space to learn how to Mod. 

    My primary question here though is, the 2.5 Patch right at this moment only applies to BG2EE?  Not BG1EE or SoD?  How long  before it's totally updated or do we know?  If there's no real "game changing content or mechanics" is it better to just let 2.5 ripen on the vine a little?


  • Patch 2.5 is about fixing and technically improving the EE. No new content but some more language options. A shaman class for IWD.



    There is no change log yet for BGEE/SoD as no release date is announced yet. EET is played all inside of BG2EE, so you get all the general improvements for the complete game after EET-core has imported your BGEE/SoD anyway.

    Here is my personal view for those interested
    My primary motivation to look into it was on behalf of the EE Mod Install Tool to make changes where necessary. Also, it supports those who found themselves to be auto-updated all of a sudden.
    To migrate to the new version for my own play, I will do it when I finished my current games which is not too soon. I feel no urgent need to scrap my current one and start anew, but that is just me.
    From the modding point of view, none of my mods will require any change so again I can take my time to see it mature,
    Last, but not least, I never gave up hope for IWD-in-EET, which would be the event that would make me switch immediately.
  • Perfect, and thanks.  Reading your spoiler lets me know we are of the same idea with it, which is what I thought.  Thanks for all of the help
  • You are my hero Roxanne! 26 hours after SCS started doing it's thing I finally have an error free install! Beyond the warnings I listed there were no issues! Thanks for getting me here!
  • hello, it's my second attempt to installing eet through ee mod setup tool but im having warnings about paladin kit and some other, is it going to be playable anyway because i dont want to start to installation again, it take ages. here is my debug log http://www.mediafire.com/file/at3l3dbpe2r543x/BWS-Debug-Installation.log . thank you for your help 
  • There is something wrong with your download link. I get this

    The file you requested has been blocked for a violation of our Terms of Service

  • sorry for that, here it's, also my installation takes days, is it normal?
  • edited July 12
    1) Installing SCS with many mods on EET can take very long. My last test took 2 hours for all of EET but extra 16 hours for SCS on top. Some reports say it took even longer for them. See http://baldursextendedworld.com/Vanilla_Forums/discussion/comment/338/#Comment_338
    2) You did not mention it, but I deduct from your log that your BG2EE is alrready at patch 2.5. This will result in some warnings from EET itself and also from some mods, e.g. Faith and Powers. These warnings occur because the mods serve both v2.3.67 and v2.5 and they contain patches for the old version that are already changed in 2.5. Nothing to worry about.
  • Thank you Roxanne!! 
  • SCS was running for 28 hours to patch EET files. But it succeeded!
    The whole other installation was done in less than 3 hours.
Sign In or Register to comment.