Reporting a Glitch in my game - CtB Ryberg Module

edited September 12 in Need Help with...
OK, I played a bit, and decided to advance the Ryberg speak with Dead Quest.  After accepting Ryberg's call for help, I eventually found a scroll of "Speak with Dead".  Ryberg was waiting in Waukeen's Promenade, and I gave Jan the scroll and had him speak with Ryberg.  The first time I tried it I forgot about the cowled wizards, and it triggered a teleport hunting party.  Oops. I reloaded, and this time I selected the option to discuss this in the Graveyard.  We all transition to a tomb indoor area, Jan reads the scroll and the "Spirit" gates in.  We select the option to speak with Ryberg's dead relative Uncle Donny.  Spirit performs a casting/gate animation, But then nothing more occurs.  Donny doesn't appear, and if you talk to the spirit again the conversation loops back to previous.  Ryberg says nothing.  The spirit is still just standing there.  Something misfired here.  I had the same problem on my last 2.5 version run, and now I'm doing a 2.6 run.

I try the console, and create Uncle Donny, and the dialogue works for a few lines.  He gives his clue and disappears.  But only previous dialogue from Ryberg will display, and the proper new text isn't being triggered.  And of course the Spirit is still there (I believe he is supposed to gate away earlier).  

Tiring of this, and not sure if it is worth messing with, I go back to the save game and try a different dialogue option, and tell him I don't think it is a good idea to speak with his dead relative, and I give him the scroll.  I get 1,000 XP, and the quest is over (although the journal entry has no update, which may be another glitch here as well).  

This is just an FYI, in case someone else has the same or similar issue.  I'm running SCS and SR, and a load of other mods, so it may be that, or not.  There is one thing that might be the cause, and that my PC is a Shadow Warrior (a FM), so he can cast Shadow Magic, but not Arcane Magic.  If the CtB module is looking for the protagonist to be a mage, then this could cause an error perhaps?  Just thinking aloud here.

Comments

  • I just tested this again and I could not reproduce the issue.

    Just to be clear
    - one of your party members must be mage or cleric in case the player is not one of those
    - the respective NPC (if not PC) must talk with Ryberg once you have the scroll, and must cast the spell from the scroll in inventory
    - the option to select a save area for casting exists only if the party has a stronghold already (regardless which)

    For other constellations, there are other outcomes, e.g. the caster must have high enough INT and STR to tame the spirit and get the right information.

    The possibility to get a "failed" outcome like you had is not a glitch.
    That leaves the issue of the spirit not leaving etc, which might be a result of some other mod making changes to spells. I could not reproduce that.
  • Thanks for looking at this Roxanne.  I have Edwin and Jan in the party, so the mage requirement should be fulfilled. I know that the Shadow Magic modder created a new set of Shadow Magic classes with new IDS numbers.  Jan has a modified 17 strength and 17 intelligence (Mage/Illusionist), and he cast the spell from scroll in inventory (from quick item slot, as is normal for a scroll).  I've played this module about a year ago, and didn't figure it out until I stumbled upon the hidden inheritance money later on in the adventure.  I was able to complete it and had no glitches.  

    Alright then.  I may revisit this another time, and try some experiments to see if I can fix it, but it may not be worth the trouble shooting any further, due to the  plethora of mods that do actually change spells that I have installed.
  • Addendum - Gave it another try.  Went to the tombs, Jan casts the spell from scroll, but this time the spirit says his lines (after I speak to him), he summons Uncle Donny, then the spirit leaves.  Uncle Donny says his bit and leaves.  So far so good.  

    Ryberg is the only one left after the spirit and Donny leave.  We are all inside the tomb.  He says nothing after this (pretty sure there was supposed to be some more dialogue).  I speak to Ryberg, but he only says 

    "What?  What does that mean, Uncle Donny?  I don't understand."  then he says
    "No Wait... don't go yet! Donny! Wait..."  END DIALOGUE

    This is what Ryberg said earlier when Uncle Donny finished his clue and disappeared.

    Is there a global or something I can check here?  I have a new saved game for this slightly better CtB Ryberg result.  But it isn't isn't quite right yet.

  • The sequence is correct, however the dialogues should be initiated by Ryberg himself.
    The global to look at is this
    C:GetGlobal("CbRybergMeetsRelative","GLOBAL") should be 4 at the time...

    >> then moves to 5 to start another dialogue in which the player gets some more options on how to further support Ryberg or not.
  • Changed it from 4 to 5.  Guess it didn't advance as was supposed to happen.  Ryberg says the correct dialogue.  I also wanted to test if after I find the inheritance, that Ryberg would detect it and finish out the quest, so I edited in the gold/item.  That worked too.

    So, it appears that my glitch was an actual temporary glitch, and almost fixed itself by reloading, and changing the global did the trick.  Not ideal, but fixable.  

    I'm satisfied with the result, and will send you a virtual high five for the help.  Cheers again!
Sign In or Register to comment.